Saturday, December 28, 2019

kubernetes: ingress - error when applying yml: apiVersion: extensions/v1beta1

Replace:
apiVersion: extensions/v1beta1

With:
apiVersion: networking.k8s.io/v1beta1

Example:
# helm install ./helmchart --name netdata -f netdata-chart-values.yaml
Error: validation failed: unable to recognize "": no matches for kind "Ingress" in version "policy/v1beta1"

Reference: https://kubernetes.io/blog/2019/07/18/api-deprecations-in-1-16/

No comments:

Post a Comment